DriverGuide
English Português Español Deutsch Français 中国 Italiano 日本語 Translate
  


DriverGuide Forums



Go Back   Free Drivers Download | Request and Support Forums > Computer Hardware Forums > Controllers (IDE, SCSI, IEEE1394, ...)

  #1  
Old 05-09-2008
tristeve tristeve is offline
Junior Member
 
Join Date: May 2008
Posts: 2
tristeve is on a distinguished road
Default Primary IDE Channel Code 19

Main problem: CD/DVD-ROM no longer recognized.

Further info: I have a yellow exclamation mark next to the Primary IDE Channel in Device Manager with the follow message under Properties:

"Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)"

If I uninstall and scan for hardware changes, the warning goes away, but my CD/DVD-ROM now has the same problem - Code 19 and the same message.

I've searched here and on Google and tried removing the Upper/Lower Filters registry setting which appears to be the most common fix.

Not sure what else to do. Any help would be appreciated,

--Steve
Reply With Quote
Sponsored Links
    
  #2  
Old 05-10-2008
Jerry K's Avatar
Jerry K Jerry K is offline
Super Moderator
 
Join Date: Sep 2003
Posts: 37,070
Jerry K is on a distinguished road
Default Re: Primary IDE Channel Code 19

Delete the IDE Controllers in Device Manager (do not reboot yet).

Now Delete any optical drives listed in Device Manager.

Next perform the "delete upper and lower filters fix"

Now reboot the machine and allow Windows to load everything back up without any user intervention. Then check in Device Manager to see if the ide controllers and optical drives are listed and not flagged.
Reply With Quote
  #3  
Old 06-21-2008
ragzeeboy ragzeeboy is offline
Junior Member
 
Join Date: Jun 2008
Posts: 2
ragzeeboy is on a distinguished road
Default Re: Primary IDE Channel Code 19

Hiya tristeve,I'm new arouind here but you never know ,a bit of fresh blood might help. This may sound crazy but have you tried a new swt of IDE cables?
I've had drives that wouldn't boot so I always try a new cable and it has solved the prob more times than you'd think. I'm sure it would fix the Primary IDE,sometimes with these unpredictable beasts the simplest way works,Oh and I apologize beforehand if you've already tried this. Cheers and best of luck, ragzeeboy
Reply With Quote
Reply [Upload Driver/Firmware]



Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT. The time now is 11:09 AM.



2017 DriverGuide is an iCentric Corporation Company.     All rights reserved.    


Powered by vBulletin Version 3.0.1
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.